Xサーバーにcomposerをインストールする方法

【解決方法】
$ curl -sS https://getcomposer.org/installer | /usr/bin/php7.1

 

【備考】
新しいエックスサーバーの場合はパイプ(|)以下は無くてもインストールできるようですが、古いエックスサーバーだと、PHP自体のバージョンが古いので、上記のコマンドでなければインストールが出来ません。

 

composerの実行自体もcomporser.pharだけだと
“PHP Fatal error: Class ‘Phar’ not found”
というエラーになってしまいますので、
$ php7.1 composer.phar
とすれば、問題なくcomposerを実行できます。

 

尚、使えるPHPのバージョンとそのパスは
https://www.xserver.ne.jp/manual/man_program_soft.php
で、確認してください。

この投稿は役に立ちましたか? 役に立った 2人中2人がこの投稿は役に立ったと言っています。